PARALLEL.RU

Дискуссионный клуб по параллельным вычислениям
Текущее время: 10 дек 18 18:14

Часовой пояс: UTC + 4 часа [ Летнее время ]




Начать новую тему Ответить на тему  [ Сообщений: 2 ] 
Автор Сообщение
СообщениеДобавлено: 14 окт 14 14:55 
Не в сети

Зарегистрирован: 12 сен 11 10:57
Сообщения: 5
При запуске гибридного кода (MPI + OpenMP) на Open MPI все потоки, созданные с помощью OpenMP, оказываются на одном ядре.
Пытался в интернете найти похожие случаи. Случаи нашел, а решение - нет. Например, здесь http://www.open-mpi.org/community/lists/users/2010/07/13875.php разработчики утверждают, что так быть не должно, но не могут понять, почему так происходит.
Поделитесь положительным или отрицательным опытом в этом направлении. Даже если вы используете другую версию MPI.


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: 14 окт 14 15:10 
Не в сети

Зарегистрирован: 11 дек 02 19:37
Сообщения: 872
Откуда: НИВЦ МГУ
Это значит, что MPI-процесс пинится на ядро (pinning). Надо проверить настройки и окружение и отключить пининг.


Вернуться к началу
 Профиль  
 
Показать сообщения за:  Поле сортировки  
Начать новую тему Ответить на тему  [ Сообщений: 2 ] 

Часовой пояс: UTC + 4 часа [ Летнее время ]


Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 2


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  
cron
Создано на основе phpBB® Forum Software © phpBB Group
Русская поддержка phpBB