PARALLEL.RU

Дискуссионный клуб по параллельным вычислениям
Текущее время: 23 сен 18 10:20

Часовой пояс: UTC + 4 часа [ Летнее время ]




Начать новую тему Ответить на тему  [ Сообщений: 15 ] 
Автор Сообщение
СообщениеДобавлено: 21 янв 13 15:14 
Не в сети

Зарегистрирован: 21 янв 13 14:59
Сообщения: 8
Добрый день. Не могу запустить задачи Lammps в параллельном режиме. http://parallel.ru/cluster/toolkitinfo#LAMMPS Здесь написано, что можно считать на GPU, но у меня не получается это сделать написанными там командами. Подскажите, как все-таки их запускать.

Спасибо


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: 30 янв 13 11:26 
Не в сети

Зарегистрирован: 11 дек 02 19:37
Сообщения: 872
Откуда: НИВЦ МГУ
Вы честно верите, что Вам ответят на вопрос "не работает notepad, скажите что делать?".

Вы не указали НИЧЕГО о том, как программа запускается и что происходит - как можно понять причину проблемы?

А вообще такие вопросы надо писать в техподдержку. Но только там тоже телепатов нет, помните это.


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: 30 янв 13 17:16 
Не в сети

Зарегистрирован: 21 янв 13 14:59
Сообщения: 8
Окей. На сайте программы написано, что программа запускается следующим образом:

1) если однопроцессорное вычисление, то lmp_serial < in.nameofthescript, где lmp_serial скомплированный файл lammps.
2) если многопроцессорное, то mpirun -np ? lmp_serial -n in.nameofthescript,

но так как на ломоносове задачи можно запускать только через sbatch, то я пробую sbatch -np ? path-to/lmp_serial -n in.nameofthescript, что не работает. В связи с этим я хочу узнать как все-таки правильно запустить задачу в многопроцессорном режиме.


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: 30 янв 13 17:44 
Не в сети

Зарегистрирован: 11 дек 02 19:37
Сообщения: 872
Откуда: НИВЦ МГУ
Ещё раз напомню про техподдержку.

По существу - что такое "не работает"? Если у вас в домашнем каталоге есть каталог _scratch, то запускаете ли вы оттуда? А может задача в очереди стоит и ещё не запустилась? Или... вариантов ещё масса.


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: 30 янв 13 19:08 
Не в сети

Зарегистрирован: 21 янв 13 14:59
Сообщения: 8
задача естественно запускается ,я же все-таки ее ставлю в очередь, но lammps некорректно работает. Обычно он не находит, что же ему запускать или же пишет другую ошибку.


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: 31 янв 13 13:18 
Не в сети

Зарегистрирован: 11 дек 02 19:37
Сообщения: 872
Откуда: НИВЦ МГУ
Простите, но я устал гадать. По этим симптомам ("пишет другую ошибку" и т.п.) сказать нельзя НИЧЕГО.


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: 1 фев 13 15:18 
Не в сети

Зарегистрирован: 21 янв 13 14:59
Сообщения: 8
Я надеялся, что кто-нибудь, кто уже считает Lammps на Ломоносове, а такие точно есть, зайдет сюда и напишет как же запускать такие задачи.


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: 2 фев 13 17:09 
Не в сети

Зарегистрирован: 21 янв 13 14:59
Сообщения: 8
В общем, сейчас дела так обстоят. Я скачал lammps по уже новой ссылке, который поддерживает задачи на GPU. Запускаю задачи так:
sbatch -n16 impi ~/path-to/lmp_mkl -i ~/path-to/in.script
после этого в slurm.out пишет текст
/tmp/slurmd/job474066/slurm_script: line 13: mpiexec.hydra: command not found


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: 4 фев 13 10:17 
Не в сети

Зарегистрирован: 11 дек 02 19:37
Сообщения: 872
Откуда: НИВЦ МГУ
А в mpienv у Вас IntelMPI выбран? Если есть каталог _scratch, то запускаете из него?


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: 5 фев 13 14:35 
Не в сети

Зарегистрирован: 21 янв 13 14:59
Сообщения: 8
Обязательно посмотрю, когда включат доступ на Ломоносов. Попробовал запустить lammps На Чебышеве.
ввел обычно mpirun -n 16 lmp_serial < in.program
вылезло вот такое в файле lmp_serial.out?
lmp_serial: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by lmp_serial)
lmp_serial: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by lmp_serial)
MPI process terminated unexpectedly
Exit code -5 signaled from node-15-03
Killing remote processes...lmp_serial: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by lmp_serial)
lmp_serial: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by lmp_serial)
lmp_serial: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by lmp_serial)
lmp_serial: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by lmp_serial)
lmp_serial: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by lmp_serial)
lmp_serial: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by lmp_serial)
lmp_serial: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by lmp_serial)
lmp_serial: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by lmp_serial)
lmp_serial: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by lmp_serial)
lmp_serial: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by lmp_serial)
MPI process terminated unexpectedly

в lmp_serial.rep ? вылезло вот это.

Task : lmp_serial
Args : lmp_serial
Nproc : 40
Exit code: 1
Output in: /home/larin/lammps/trying/CNT/lmp_serial.out-315277
Work dir : /home/larin/lammps/trying/CNT
Work time: 0 hours 0 minutes 3 seconds
Report : http://t60-2.parallel.ru/cleo-reports/t ... niqid.html
Started : Tue Feb 5 01:40:47 2013
Nodes : node-01-04:1,node-01-04:2,node-01-04:3,node-01-04:4,node-01-04:5,node-01-04:6,node-01-04:7,node-01-04:8,node-06-05:1,node-06-05:2,node-06-05:3,node-06-05:4,node-06-05:5,node-06-05:6,node-06-05:7,node-06-05:8,node-15-03:1,node-15-03:2,node-15-03:3,node-15-03:4,node-15-03:5,node-15-03:6,node-15-03:7,node-15-03:8,node-19-06:1,node-19-06:2,node-19-06:3,node-19-06:4,node-19-06:5,node-19-06:6,node-19-06:7,node-19-06:8,node-20-08:1,node-20-08:2,node-20-08:3,node-20-08:4,node-20-08:5,node-20-08:6,node-20-08:7,node-20-08:8

Serg скажите в чем проблема?


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: 7 фев 13 9:51 
Не в сети

Зарегистрирован: 11 дек 02 19:37
Сообщения: 872
Откуда: НИВЦ МГУ
Версия библиотеки разная на Чебышёве и Ломоносове. Бинарные файл с одного кластера не надо запускать на другом, даже если заработает, то врядли хорошо.


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: 20 фев 13 17:21 
Не в сети

Зарегистрирован: 21 янв 13 14:59
Сообщения: 8
После обновления ситуация такая. После загрузки module impi/4.x.x/ и cuda/5.0.3.5 ввожу команду
sbatch -n16 impi ~/path-to-lammps/lmp_mkl -i ~/_scratch/path-to-script/in.script
Вылазит 16 раз ошибка
/home/users/../_scratch/lammps/lmp_mkl: error while loading shared libraries: libcudart.so.4: cannot open shared object file: No such file or directory


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: 20 фев 13 18:04 
Не в сети

Зарегистрирован: 11 дек 02 19:37
Сообщения: 872
Откуда: НИВЦ МГУ
добавьте mofule load mkl


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: 20 фев 13 18:44 
Не в сети

Зарегистрирован: 21 янв 13 14:59
Сообщения: 8
я забыл сказать, но модуль mkl/4.0.2.146 тоже загружен..


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: 21 фев 13 9:21 
Не в сети

Зарегистрирован: 11 дек 02 19:37
Сообщения: 872
Откуда: НИВЦ МГУ
Перекомпилируйте программы - версия cuda обновилась до 5.

Пожалуйста, задавайте вопросы в техподдержку.


Вернуться к началу
 Профиль  
 
Показать сообщения за:  Поле сортировки  
Начать новую тему Ответить на тему  [ Сообщений: 15 ] 

Часовой пояс: UTC + 4 часа [ Летнее время ]


Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  
cron
Создано на основе phpBB® Forum Software © phpBB Group
Русская поддержка phpBB